Freeside talk:1.7:Documentation:InstallingOnCentOS4

From Freeside
Jump to: navigation, search


 The mod_perl2 required newer version of CGI (>= 3.08), that provided by upgrading perl.


 service httpd-freeside start
 Starting httpd-freeside: [Sun Mar 04 02:02:17 2007] [error] CGI version 3.08 is required to support \
  mod_perl2 API at /usr/lib/perl5/vendor_perl/5.8.5/HTML/Mason/ line 339.\nCompilation \
  failed in require at /etc/freeside/ line 15.\nBEGIN failed--compilation aborted at \
  /etc/freeside/ line 15.\nCompilation failed in require at (eval 2) line 1.\n


 Enabling centosplus repo will solve the issue.
 yum --enablerepo=centosplus upgrade perl

TBB/anyone else: